Emails not sending

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 10:16 EST

Investigating

We're currently investigating a Hypixel Forums issue causing some emails to not be sent, such as new account verification emails.

Emails sent from other services, such as Hypixel Support and the Hypixel Store, continue to work as expected.
Posted Feb 16, 2026 - 08:59 EST
This incident affected: Forums.