SkyBlock Joining Disruption

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 23:24 EDT

Investigating

We are currently investigating issues with joining SkyBlock.
Posted Jul 01, 2026 - 13:18 EDT
This incident affected: Minecraft Server Games (SkyBlock).