SkyBlock Profiles Maintenance
Incident Report for Hypixel
Resolved
SkyBlock is now open to all players. We are not aware of any issues after the profile changes, if you come across any bugs please report them https://hypixel.net/bug-reports/create
Posted May 16, 2023 - 19:31 EDT
Monitoring
SkyBlock is still undergoing maintenance for profile structure changes and migration and we are monitoring the results.
Posted May 16, 2023 - 17:03 EDT
This incident affected: Minecraft Server Games (SkyBlock).