Emergency Maintenance
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Jun 24, 2021 - 18:24 EDT
Monitoring
The Hypixel Server is now open to all players.
Posted Jun 22, 2021 - 19:27 EDT
Update
The Hypixel Server is now open in a limited maintenance mode, which allows ranked players to join.

More info > https://hypixel.net
Posted Jun 22, 2021 - 12:35 EDT
Update
We have the new hardware configured, but we still need more time for set up and for our external partners to do what they need to do. But you can read more about it on the website > https://hypixel.net/
Posted Jun 20, 2021 - 13:46 EDT
Update
A progress bar has been added to the website to show how much more needs to be done before we can get up and running again. Additionally, we posted an update regarding what's going on with the maintenance, so be sure to check it out > https://hypixel.net/

If you are having trouble seeing this new update, make sure to press CTRL and F5 at the same time while on the page to refresh the cache.
Posted Jun 19, 2021 - 11:44 EDT
Update
The Hypixel Network will be down for emergency maintenance starting now. We are sorry for any inconvenience and thank you for being patient with us. You can read more at https://hypixel.net
Posted Jun 17, 2021 - 20:33 EDT
Update
We are continuing to work with our upstream provider to resolve this. We have resolved the issue of some players being unable to connect.

We appreciate your patience and support as we work to resolve these issues.
Posted Jun 16, 2021 - 19:31 EDT
Update
We are continuing to work with our upstream provider to implement a way to fully resolve this issue. We are also aware of some players being unable to connect completely at this time.

We appreciate your patience and support as we work to resolve these issues.
Posted Jun 16, 2021 - 18:38 EDT
Identified
We are aware of the issue still existing and are working on a larger solution with our provider. This may take some time and we'll keep this incident updated.
Posted Jun 16, 2021 - 07:30 EDT
Monitoring
Upstream has implemented a change and we are monitoring the results.
Posted Jun 15, 2021 - 21:55 EDT
Identified
We are aware of the connection issues occurring again and are working with our upstream provider.
Posted Jun 15, 2021 - 20:37 EDT
Monitoring
Upstream has implemented a change and we are monitoring the results.
Posted Jun 15, 2021 - 19:38 EDT
Update
We are continuing to work with the upstream provider to resolve the issues as soon as possible
Posted Jun 15, 2021 - 15:33 EDT
Identified
We have identified the issue with an upstream provider and are working with them to resolve it as soon as possible.
Posted Jun 15, 2021 - 15:03 EDT
Investigating
We are currently investigating an issue with intermittent connection issues to the Minecraft Server and Forums.
Posted Jun 15, 2021 - 15:00 EDT
This incident affected: Minecraft Server Games (SkyBlock, Hypixel SMP, Bed Wars, SkyWars, Murder Mystery, Housing, Build Battle, Arcade, Prototype Lobby, The TNT Games, The Pit, UHC Champions, Classic Lobby, Mega Walls, Blitz SG, Cops and Crims, Smash Heroes, Warlords, Duels) and Forums, Public API.