Server Performance
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Sep 03, 2023 - 17:23 EDT
Investigating
We are aware of the degraded performance on the server and are working on resolving the issue.
Posted Sep 03, 2023 - 10:01 EDT
This incident affected: Hypixel Minecraft Server.