Connectivity Issues

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Sep 22, 2026 - 08:24 EDT

Monitoring

We see connectivity returning back to normal, but we are still monitoring.
Posted Sep 22, 2026 - 07:29 EDT

Update

We are continuing to investigate this issue.
Posted Sep 22, 2026 - 07:13 EDT

Investigating

We are currently investigating connectivity issues across the network.
Posted Sep 22, 2026 - 05:17 EDT
This incident affected: Hypixel Minecraft Server, Forums, and Public API.