SkyBlock Emergency Maintenance
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Apr 23, 2021 - 11:41 EDT
Investigating
SkyBlock is currently undergoing emergency maintenance as we investigate an issue.
Posted Apr 23, 2021 - 10:05 EDT
This incident affected: Minecraft Server (SkyBlock).