Support Outage
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted May 17, 2021 - 09:20 EDT
Update
We are aware of an issue causing the Hypixel Support site to be unavailable. We are in contact with the upstream provider to resolve this as soon as possible.

In the meantime, users can email support@hypixel.net directly.
Posted May 17, 2021 - 05:35 EDT
Identified
We are aware of an issue causing the Hypixel Support site to be unavailable and are working to resolve as soon as possible.
Posted May 17, 2021 - 02:40 EDT
This incident affected: Support.