Players unable to login

Incident Report for Hypixel

Investigating

We are still seeing this issue persist intermittently with our upstream provider and are working with them to resolve it.
Posted Mar 05, 2026 - 06:54 EST

Monitoring

We are seeing improvements in player logins and are monitoring.
Posted Mar 05, 2026 - 06:18 EST

Investigating

We are seeing the issue persist with our upstream provider and are working with them to resolve it.
Posted Mar 05, 2026 - 04:01 EST

Monitoring

A fix has been implemented by the upstream provider and we are now monitoring.
Posted Mar 05, 2026 - 03:15 EST

Investigating

We are currently investigating an issue with an upstream provider, resulting in players being unable to log in to the Minecraft Server.
Posted Mar 04, 2026 - 23:44 EST
This incident affects: Hypixel Minecraft Server.