Purchases failing to process and in-game store disabled
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Aug 15, 2023 - 16:21 EDT
Monitoring
We have identified the issue and we are now processing MVP++ ranks again, we have also now re-enabled the in-game store and are monitoring.
Posted Aug 15, 2023 - 15:59 EDT
Investigating
We are currently investigating an issue with some purchases such as MVP++ not being processed from store.hypixel.net. We are also investigating issues with the in-game store and it is disabled at this time.
Posted Aug 15, 2023 - 15:32 EDT
This incident affected: Store.