Hypixel Forums unavaliable
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Jan 02, 2022 - 20:21 EST
Investigating
We are investigating an issue where the Hypixel Forums/Website is not accessible.
Posted Jan 02, 2022 - 20:18 EST
This incident affected: Website.