[SkyBlock] Museum Browser Disabled
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Aug 12, 2024 - 18:06 EDT
Monitoring
A fix has been implemented, the museum browser is now enabled again, and we are monitoring the results.
Posted Aug 12, 2024 - 13:56 EDT
Investigating
We are currently investigating issues with the museum browser in Hubs, as a result it has been temporarily disabled.
Posted Aug 10, 2024 - 17:32 EDT
This incident affected: Minecraft Server Games (SkyBlock).