Pit Emergency Maintenance

Incident Report for Hypixel

Resolved

The Pit is now reopened. Information on the emergency maintenance can be found at https://hypixel.net/threads/6114447/
Posted Jun 25, 2026 - 05:42 EDT

Investigating

The Pit is currently unavailable due to emergency maintenance.
Posted Jun 23, 2026 - 07:10 EDT
This incident affected: Minecraft Server Games (The Pit).