Support Response Delays
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Dec 08, 2020 - 11:21 EST
Investigating
We're currently experiencing a technical issue with our support site, please allow extra time for a response. Tickets can still be submitted through https://support.hypixel.net
Posted Dec 08, 2020 - 07:26 EST
This incident affected: Support.