Hypixel Store Login Unavailable

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 08:05 EDT

Identified

We're monitoring an issue preventing some users from logging into the Hypixel Store. We're waiting for a resolution from our upstream provider and will post an update as soon as the issue is resolved.

Users who are able to login to Hypixel Store are not affected and purchases are still being processed normally. This issue only affects the Hypixel Store login page.
Posted Jun 12, 2025 - 16:24 EDT
This incident affected: Store.