High latency for Europe connections
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 19:05 EDT
Monitoring
Our upstream provider has implemented a fix and we are monitoring.
Posted Oct 03, 2022 - 17:23 EDT
Investigating
We are currently investigating an issue with our upstream provider resulting in higher latency for players in Europe.
Posted Oct 03, 2022 - 13:00 EDT
This incident affected: Hypixel Minecraft Server.