SkyBlock Profile Visibility

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 03:51 EDT

Investigating

We are currently investigating a profile visibility issue. We have identified a small subset of users who have had their profiles visually removed from in-game menus/API etc. Note that these profiles are not wiped and their data is still intact. We are aiming to restore everyone affected by this shortly.
Posted Apr 14, 2026 - 02:43 EDT
This incident affected: Minecraft Server Games (SkyBlock).