Forums Outage
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 12:09 EDT
Investigating
We are currently investigating an issue with the Hypixel Forums/Website being unaccessible.
Posted Jul 23, 2021 - 12:01 EDT
This incident affected: Website.