Support Unavailable
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Dec 13, 2020 - 21:13 EST
Identified
The support upstream provider is working to resolve this issue and are expecting to be operational again within 4 hours.
Posted Dec 13, 2020 - 16:03 EST
Investigating
We are currently investigating this issue.
Posted Dec 13, 2020 - 12:47 EST
This incident affected: Support.