Network Connection Issues
Incident Report for Hypixel
Resolved
Changes have been implemented to improve the issues that occurred on Wednesday.
Posted Dec 04, 2021 - 20:23 EST
Update
We are still continuing to implement a solution for the issues that occurred earlier today.
Posted Dec 01, 2021 - 13:13 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 01, 2021 - 10:17 EST
Investigating
We are currently investigating an issue with players and high latency and connection issues to the server.
Posted Dec 01, 2021 - 09:56 EST
This incident affected: Minecraft Server Games (SkyBlock, Hypixel SMP, Bed Wars, SkyWars, Murder Mystery, Housing, Build Battle, Arcade, Prototype Lobby, The TNT Games, The Pit, UHC Champions, Classic Lobby, Mega Walls, Blitz SG, Cops and Crims, Smash Heroes, Warlords, Duels).