Minecraft Server Connection Issues

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 13:57 EDT

Monitoring

We are seeing improvements in player connections and are monitoring.
Posted Jul 23, 2025 - 10:19 EDT

Investigating

We are currently investigating an issue with our upstream providers, resulting in connections having increased latency.
Posted Jul 23, 2025 - 07:28 EDT
This incident affected: Hypixel Minecraft Server.