SkyBlock Backend Disruption

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 20:55 EDT

Investigating

We are currently investigating issues related to disruptions on various backend services providing features like island guesting, Auction House, and Bazaar.
Posted Jun 19, 2025 - 20:29 EDT
This incident affected: Minecraft Server Games (SkyBlock).