Increased Player Latency

Incident Report for Hypixel

Resolved

This incident has been resolved.
Posted Oct 14, 2024 - 17:02 EDT

Monitoring

We're seeing improvements at this time and will continue monitoring.
Posted Oct 14, 2024 - 12:29 EDT

Investigating

We are investigating an issue with an upstream provider that is causing a heavy increase in latency to the Minecraft Server for some players.
Posted Oct 14, 2024 - 06:48 EDT
This incident affected: Hypixel Minecraft Server.