Regional Packet Loss
Incident Report for Hypixel
Resolved
This incident has been resolved.
Posted Nov 28, 2024 - 19:29 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2024 - 02:57 EST
Identified
Since last Friday, we’ve been aware of ongoing regional packet loss affecting some users. The cause of the issue has been identified, and it’s with one of our upstream providers. Unfortunately, we don't have an ETA for a resolution, but we continue pushing for a fix.

We’re sorry for the inconvenience this is causing and appreciate your patience. We’ll share more updates as soon as we have them.
Posted Nov 21, 2024 - 16:20 EST
This incident affected: Hypixel Minecraft Server.